เมื่อบันทึกข้อมูลแสดง #DELETED



0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

22 ต.ค. 61 , 07:14:09
อ่าน 692 ครั้ง

แดนชัย

เมื่อบันทึกข้อมูลแสดง #DELETED
« เมื่อ: 22 ต.ค. 61 , 07:14:09 »
เรียนท่านอาจารย์ทุกท่าน
 ขอความช่วยเหลือครับ
   1.ผมมีฟอร์มหลักที่ใช้งานประจำเพื่อบันทึกข้อมูลเข้าระบบฐานข้อมูล Mysql ใช้งานได้ตามปกติ(เนื่องจากใช้ล๊อกจังหวัดและอำเภอไว้...เลือกเฉพาะตำบล(เชื่อมโยงตาราง)
   2.ผมปรับปรุงให้แสดงเป็น จังหวัด อำเภอ ตำบล (โดยใช้การเชื่อมโยงตาราง สามารถเลือกได้ตามปกติ ตามที่เขาใช้กัน) มีปัญหาที่เกิดขึ้น
        2.1 ถ้ามีฐานข้อมูลเดิม...ปรับเปลี่ยน..จังหวัด อำเภอ ตำบล ได้ บันทึกได้ตามบปกติ
        2.2 ผม Add newrecord...กรอกข้อมูลได้ตามปกติ เมื่อกดบันทึก.....ข้อมูลไปเก็บยังฐานข้อมูล Mysql ปกติ  แต่หน้าฟอร์มแสดง....#DELETED....ทุกฟิว ไม่ทราบเกิดจากอะไร
 

 

23 ต.ค. 61 , 13:39:17
ตอบกลับ #1

สันติสุข

: เมื่อบันทึกข้อมูลแสดง #DELETED
« ตอบกลับ #1 เมื่อ: 23 ต.ค. 61 , 13:39:17 »
มีฝรั่งแนะนำให้อ่านอันนี้ https://dev.mysql.com/doc/connector-odbc/en/connector-odbc-usagenotes-apptips-microsoft-access.html link
ช่วยพกถุงผ้า/ถุงพลาสติกใช้แล้วไปซื้อของเพื่อลดการใช้พลาสติก ขยะ รักษาสิ่งแวดล้อม และไม่ให้ภาวะโลกร้อนวิกฤติเร็วขึ้นกว่านี้
ช่วยคลิกโฆษณาข้างล่างนี้ เพื่อสนับสนุนเวปบอร์ดด้วยครับ
:nice day:
 

25 ต.ค. 61 , 06:47:43
ตอบกลับ #2

แดนชัย

: เมื่อบันทึกข้อมูลแสดง #DELETED
« ตอบกลับ #2 เมื่อ: 25 ต.ค. 61 , 06:47:43 »
ขอบคุณมากนะครับ...จะลองศึกษาดู

 

25 ต.ค. 61 , 23:10:39
ตอบกลับ #3

อุดมโชค สมหวัง

  • สมาชิกไท.Access
  • กระทู้: 1

    • ดูรายละเอียด

: เมื่อบันทึกข้อมูลแสดง #DELETED
« ตอบกลับ #3 เมื่อ: 25 ต.ค. 61 , 23:10:39 »
เรียนท่านอาจารย์ทุกท่าน
 ขอความช่วยเหลือครับ
   1.ผมมีฟอร์มหลักที่ใช้งานประจำเพื่อบันทึกข้อมูลเข้าระบบฐานข้อมูล Mysql ใช้งานได้ตามปกติ(เนื่องจากใช้ล๊อกจังหวัดและอำเภอไว้...เลือกเฉพาะตำบล(เชื่อมโยงตาราง)
   2.ผมปรับปรุงให้แสดงเป็น จังหวัด อำเภอ ตำบล (โดยใช้การเชื่อมโยงตาราง สามารถเลือกได้ตามปกติ ตามที่เขาใช้กัน) มีปัญหาที่เกิดขึ้น
        2.1 ถ้ามีฐานข้อมูลเดิม...ปรับเปลี่ยน..จังหวัด อำเภอ ตำบล ได้ บันทึกได้ตามบปกติ
        2.2 ผม Add newrecord...กรอกข้อมูลได้ตามปกติ เมื่อกดบันทึก.....ข้อมูลไปเก็บยังฐานข้อมูล Mysql ปกติ  แต่หน้าฟอร์มแสดง....#DELETED....ทุกฟิว ไม่ทราบเกิดจากอะไร
 

ลองดูเรื่อง index ของ table ที่เก็บข้อมูลด้วยนะครับ

 


บอร์ดเรียนรู้ Access สำหรับคนไทย